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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For example,
“copy file1” means you must type the word copy, then type a space, and then type
file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to press
the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then type a
space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and
contains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Schematic > Line"

This instruction means that you should click the Line command on the Schematic ribbon
tab. An image of the command icon, or a partial view of the ribbon, is often included with
the instruction.
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l Themenu bar (located above the ribbon) is a group of the main commands of an
application arranged by category such File, Edit, View, Project, etc. An example of a
typical user interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
The focus of this tutorial is exploring an IoT Module example using EMIT's personal library
models and desense results metrics.

Key Concepts
l Importing and using personal library models
l Exploring EMIT's desense results metrics

Introduction 1-1
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2 - Model Setup
Before building the model for this tutorial, perform the following steps to populate the personal
library with some pre-made models.

First, select Tools >Options >General Options. ExpandGeneral options in the tree and
select Directories. The PersonalLib Directory is where all personal libraries and elements
created will be stored. Either change this to something you'll easily remember, or take note of the
current directory before performing the next steps.

In Windows File Explorer, navigate to [AEDT Installation Directory]\Win64\ Examples\ EMIT\
Tutorials\Tutorial 8.

In this folder, you will find an .aclb file and an .aslb file. Copy these files into the PersonalLib
directory noted earlier.

Important:

If Ansys Electronics Desktop is still open, you must restart it in order to update the
Component Libraries with the new models added to the personal library.

In AEDT, select File >Open Examples.Navigate to EMIT \Tutorials \Tutorial 8 and select the
IoT_Module file. Select a location to extract this archive file and clickOpen.

The Restore Archive window appears, with a progress bar. It may take a few moments to
restore the archive. Once the restoration has completed, close this window.

Model Setup 2-1
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Verify that the project contains 3 designs:

l 2 HFSS designs named Baseline and Shielded
l 1 EMIT design named IoT_Module_Solved

Note:

The Shielded design is an iteration on the Baseline design with added shielding, Via
Fences, etc. added throughout. Feel free to explore both designs in HFSS.

Next, verify that the Component Libraries window contains the models copied to the
PersonalLib directory. They should appear under Personal Libraries:

Model Setup 2-2
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Note:

If the Component Libraries window is not visible, enable it one of two ways:

l From the Viewmenu, select Component Libraries.
l From the View ribbon, select Docking Windows > Component Libraries.

Model Setup 2-3
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3 - Building the Design
Create a new EMIT design within the current project by navigating to the Desktop ribbon and
clicking EMIT.

In the Project Manager, a new design called EMIT Design1 appears.

Note:

If an Add Coupling Link window appears, click Cancel. Coupling will be covered later
in the tutorial.

Open EMIT Design1 by double-clicking its name.

Next, insert the emitters added to the personal library into the design. From the
Component Libraries window, expand Personal Libraries. LocateMIPI D-PHY v3.0 Clock
andMIPI D-PHY v3.0 Data. Drag and drop one instance of each into the design:

Next, place a WiFi radio in the design. In the Component Libraries window, expand EMIT
Elements > Radios > Commercial Unlicensed Systems >WiFi. Place one instance ofWiFi –
802.11-2012 into the design.

Building the Design 3-1
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From the Schematic ribbon, click Antenna. This automatically connects an antenna to the WiFi
radio:

Next, configure the emitters and radio.

Building the Design 3-2
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Right-click theMIPI D-PHY v3.0 Clock emitter and select Configure. This tutorial's first
simulation will only evaluate the HS Clock 80 Mbps data rate, so deselect all of the other check
boxes:

Right-click theMIPI D-PHY v3.0 Data emitter and select Configure. Again, deselect all check
boxes except HS Clock 80 Mbps:

Right-click theWiFi radio and select Configure. Expand the HR-DSSS folder and enable the
HR-DSSS Rx – Ch 1-13 band.

Building the Design 3-3
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Building the Design 3-4
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4 - Running the Initial Simulation
Before running a simulation of the design, save the project.

Next, open the simulation window one of two ways:

l From the Simulation ribbon, click Analyze.
l From the Project Manager, right-click EMIT Design1 and select Analyze.

Once the window has opened, click Run.

After the simulation runs, the scenario matrix updates with color codes:

Running the Initial Simulation 4-1
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The threshold values for the color coding can be changed in the By EMI Margin tab at the
upper-right.

Results can also be filtered using the By Problem Type tab:

Running the Initial Simulation 4-2
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Feel free to explore how different filter combinations affect the simulation results.

EMIT can also isolate results by Tx/Rx. To view channel-specific results, select the HS Data 80
Mbps band in the Transmitters window and the HR-DSSS Rx band in the Receivers window.

This updates the window to display channel-level interference results.

Next, modify the simulation to enable all data rates for both emitters. To do so, close the
simulation window. Then open the configuration window for each emitter and enable all data
rates:

Running the Initial Simulation 4-3
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Changing the configuration of components in the design causes the previous results to have an
X through them in the Project Manager:

Old results can still be viewed, but they are no longer valid for the current modified design.

To run a new simulation:

Running the Initial Simulation 4-4
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l From the Simulation ribbon, click Analyze, or
l From the Project Manager, right-click EMIT Design1 and select Analyze.

This will open the simulation window and create a new revision in the Project Manager.

Click Run.

Notice that the results are different from the last simulation and that the EMI margin for the
WiFi/Clock pairing has gotten worse. Similar to the last simulation, you can drill down into the
results to further investigate the interference.

To isolate just the WiFi/Clock results, select that square in the scenario matrix.

Running the Initial Simulation 4-5
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This updates the results to show only interference between that Tx/Rx pair.

The worst-case EMI margin is now 13.7 dB and it is caused by a Fundamental:

To further investigate this problem, select the By Problem Type tab. Under All Rx Out-of-
Channel, deselect Tx Fundamental.

The EMI Margin is now 4.2 dB and a problem still exists with a Harmonic:

Running the Initial Simulation 4-6
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Deselect Tx Harmonic/Spurious:

The EMI Margin is now -18.5 dB and there is no longer a problem:

Running the Initial Simulation 4-7
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This is one way to isolate EMI problems. Another method is to use the results plot to zoom in and
move the black arrow around to investigate problems.

Close the simulation window.

To mitigate the out-of-band problem, add a bandpass filter to the WiFi radio using the steps
below.

Drag the antenna to the right to make space for the bandpass filter. Next, select the cable
between the WiFi radio and the antenna and press Delete.

Running the Initial Simulation 4-8

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with EMIT - Tutorial 8

A preconfigured bandpass filter is available in the Personal Library we imported earlier. Drag
and drop the Filter in the EMIT_Training library into the schematic and connect it between the
WiFi radio and the antenna:

Relaunch the simulation window and notice that clock interference has come down significantly.

Running the Initial Simulation 4-9

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with EMIT - Tutorial 8

5 - Coupling
To open the Coupling Editor:

l From the Project Manager, right-click Coupling and select Coupling Editor, or
l From the Simulation ribbon, click Coupling Editor.

Initially, two values can be set in this window: Minimum Allowed Coupling and Global Default
Coupling. The Global Default Coupling is initially set to 0 dB, which is not realistic, but it is not
uncommon to run simulations with this value as a starting point.

For more realistic scenario, suppose we suspect we can achieve at least 20 dB of isolation.
Change theGlobal Default Coupling value to -20 dB, clickOk, and rerun the simulation to see
the impact of coupling on the results.

Next, bring in the Baseline HFSS design using coupling. From the Project Manager, click and
drag the Baseline design into EMIT Design 1's Coupling folder.

If you are prompted to create antennas, select No, as this is already configured.

The Coupling Editor appears, populated with a list of terminals from the HFSSmodel listed as
ports:

Coupling 5-1
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Use the drop-down menus to match terminals from the HFSSmodel to the EMIT model as
follows:

l Camera1_T1: MIPI D-PHY Clock
l Camera3_T1: MIPI D-PHY Data
l WiFi_Antenna_T1: Antenna

The scenario matrix in the Coupling Editor updates with HFSS icons that can be clicked to
display the coupling plot:

Coupling 5-2
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ClickOk and rerun the simulation.

The results show that the EMI margin is further improved. You can investigate and filter the
results as we did previously.

To organize your results, delete all the results in the Project Manager that have an X through
them by right-clicking and selecting Delete. Rename the most recent results to "Baseline 3Port"
by right-clicking and selecting Rename.

When all invalid results have been deleted, save the project.

Next, disconnect the Baseline coupling and connect the Shielded HFSS design. To do so,
expand Coupling in the Project Manager. Right-click Baseline and select Delete. A red X
appears through the "Baseline 3Port" results because the results are no longer valid; however,
you can still view the results at any time to compare. Drag and drop Shielded into the Coupling
folder.

If you are prompted to create antennas, select No, as this is already configured.

The Coupling Editor appears, populated with a list of terminals from the HFSSmodel listed as
ports.

Use the drop-down menus to match terminals from the HFSSmodel to the EMIT model as
before:

Coupling 5-3
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l Camera1_T1: MIPI D-PHY Clock
l Camera3_T1: MIPI D-PHY Data
l WiFi_Antenna_T1: Antenna

ClickOk and rerun the simulation.

This result shows the performance improvement achieved from usual mitigation strategies for
improving isolation from unintended radiators.

While this example only explored 3 defined ports, the IoT_Module_Solved EMIT design defines
all ports from the HFSSmodel. To explore those results, select File >Open Examples.Navigate
to EMIT \Tutorials \Tutorial 8 and select Tutorial8.aedt.

Coupling 5-4
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This concludes Tutorial 8.

Coupling 5-5
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